Category Archives: router

A5 V11 Router

A5-11 RouterOr – the cheapest router on the planet – probably. I should say at the outset this experiment did not end too well – currently waiting for another unit to arrive – but worth a read in case you’re about to embark on using this unit.

I had to pick one up – at just a few quid (I paid £3.82 but I note they’ve put the price up to £4.41) I could not help myself. 2 weeks ago I ordered this unit from China and this morning it turned up.

Of course once I’d received it (in a very pretty package comprising the 3g router, a USB lead and instructions in Chinese and English) I had to go off to find out how to actually make use of it.

Here’s the specification for those interested:

  • SoC – Mediatek/Ralink) RT5350F MIPS processor @ 360MHz
  • System Memory – 32MB RAM (W9825G6EH-75).
  • Storage – 4MB NAND flash (Pm25LQ032)
  • Connectivity – Wi-Fi 802.11b/g/n up to 150 Mbps; 1x 10/100M Ethernet
  • USB – 1x USB 2.0 host port, 1x micro USB port for power
  • Misc – Power LED, factory reset pinhole
  • Power – 5V via micro USB port
  • Dimensions –  6.1 x 2.3 x 1.4 cm

     

    So – typically instructions on the web were not at first a lot of use - “The unit will default to 192.168.100.1. Plug into your network and connect” – log into it… well that’s fine except you CAN’T unless you happen to have a 192.168.100.x setup !!

    shellAnyway as it turns out  - when I plugged power into the little unit, and plugged a network cable in, it adopted an address on my network – 192.168.1.42

    web interfaceAnd so off I went to find Telnet on my PC – and sure enough with username and password admin and admin I found an utterly useless shell! But then I noted in the instructions something about a web page – seems reasonable as routers usually have web pages – and lo – a web interface!!

    A good start –of course the idea of buying this was to fit it out with openWRT and MQTT to truly make the cheapest MQTT-based home network on the planet.. but I had to have a play in the meantime. Considering these things have 4Mbit of Flash, this is not a bad start.

    I could not test the 3g side as I don’t have a 3g dongle (my phone has data for months over here in Spain before THREE decide I’ve been here too long so no need for one). So I tried changing the WLAN settings – surprising amount of info in there – well impressed at the price.

    The WIFI signal, with the unit lying horizontally was somewhat down from a “proper” router but sitting vertically, from the next room I noted a signal almost as good as my TP-Link.

    SpeedtestI decided, silly as it seemed to go for a speed test. I mean – what DO you expect for £4?

    I connected my phone via WIFI to the router. Incidentally all of the operations I tried needed a reboot of the unit - I guess they had to take shortcuts somewhere - but no problem as it only took a few seconds each time. With the dish-connected WIFI we have here in Galera, I get around 10Mbps download and 3Mbps upload. I ran the speed test (Speedtest.net) on my phone while using the unit as a router – no more than a metre away from the little unit. I have to say, impressed I was!!! I’m thinking of ordering another one just for that use alone! 

    I mean, if nothing else, just for some extra range in the house without cluttering the place up with kit – this thing is smaller than the power supply you need to power it!!! Apparently we’re looking at 300ma at 5v (so, 1.5w) so the most rubbish USB supply would do the job. The unit itself was at this point slightly warm, nothing more. For heaven’s sake it even has NTP time synchronisation.

    Next, I noted something about “network storage” – which was enabled… I grabbed a handy FAT32-formatted USB stuck and put a (780MB) movie on it – and plugged the USB stick into the router unit (this is all guesswork)… I noted that the stick was not hing special speed-wise as it had taken an age to copy the movie over (nearly 3 minutes) on my fast PC.

    Here’s where I hit a snag – despite network storage being enabled-  I could not figure out how I might use this – the IP address was already being used for the web interface – and the instructions for network storage were non-existent. A quick look on my PC for devices showed nothing.

    So, on the off-chance, I went into file explorer on the PC and typed \\192.168.1.42  -  sure enough it asked for a user and password – the default was still set at admin and admin – and lo – a directory called MEDIA appeared. Within that directory was a folder for system information-  and my movie.  I clicked on the movie…. and sure enough – it worked.

    RouterWell impressed by all of this – I left that running on the PC… no stuttering…. just working. I went to the phone which was still at this point connected to the little unit wirelessly. ES File Explorer – streaming media player – sure enough – the movie played simultaneously on my PC (hardwired to the net work) and the HTC One M8 phone.

    At this point I was beginning to wonder if I really wanted to upgrade this little unit to something else – it just works SO well for it’s size and price. DMZ, DDNS – oh and of course the point is it is supposed to provide WIFI and WIRED access from a dongle - but I could not test the latter.

    Static routing and MAC-Binding – how on EARTH did they fit all this stuff in such a small space and for that price – this thing has more useful features than the utterly useless router that Plusnet gave me, back in the UK!!!

    I used the little SHELL software I referred to earlier – and despite the list of instructions being minimal – actually, it responds to far more instructions including cat /proc/meminfo which immediately told me this unit had the full 32MB of memory -  apparently other units often have only 16GB.

    Feeling REALLY ambitious? Check out this guy’s video and blog – he apparently has DEBIAN running on it!!!

    http://board.nwrk.biz/viewtopic.php?pid=342

    https://www.youtube.com/watch?v=pZLU15zx1EU

    upgradingIn reality, all I wanted was to try Open Router for the ability to run MQTT on this little box.  So, using software from here… I used the standard upgrade option in the menu to load the image – with a warning that a bad image would BRICK the router…. 2 minutes later – everything said “100%” – but of course – no more visuals as it was sitting on the same address as my main router at 192.168.1.1  presumably?

    By now I was wondering if this was such a good idea…. the original blue light on the little router was now flashing white and blue!!!  I figured that MUST be a good sign and took the whole lot over to my laptop and plugged the router into the laptop – so that this was a completely separate network.

    Erm, no. After a couple of reboots, I ended up with the device still fitted with original Qualcomm software – and now on it’s own address range of 192.168.100.1 – I guessed that – and sure enough – it was running DHCP. I changed the address to that of my network – and disabled DHCP and I was back to square one. (it turns out you need a better bootloader as this one won’t take unofficial software updates!!)

    And that’s where I am up to now – this I can see is going to be a long blog… but I thought you might like to see where I’m up to – even at this point I think this is a must-have gadget at the price. If I can get MQTT on it – that’ll be a bonus.

    Right now – to update this unit to OpenWrt – you need to put in a new bootloader, the original won’t let you use a non-official image…. that’s fine – except the TFTP to let you put that in – isn’t supplied with the module. Also you need to load a smaller version of OpenWrt to load the bigger one – and the links for that are dead (along with most of the links for the bootloader). Some very much out of date material out there.  If anyone has a known working Busyboxlink (with known working links in it) I’m sure lots of us would benefit. I found a usable link for the bootloader - https://github.com/wertwert4pda/rt5350f-uboot

    But I don’t THINK that is useful on it’s own. Some links suggest putting the file on a website and WGET it – no wget in BusyBox shell!!!

    After changing the IP address of the unit and turning off DHCP – I found that all worked well until the next reboot – and then the unit would not come back to the same address or indeed respond to any address -  and needed restoring to factory settings with a pin. 

    At this point I was considering cutting my wrists when I stumbled across this. https://hackaday.io/project/11037-running-rtl-sdr-on-a5-v11-3g4g-router

    Off I went – and sure enough the files I needed were there.  I realised there was a wget command in there and as usual “just whip out your Linux computer”  to run a webserver to serve the file up – right. Anyway, I discovered MONGOOSE web server – a one-file webserver that sets up shop in the directory in which you run the program – marvelous.

    With that I was able to follow the instructions in the Hackaday blog. Well, almost – the file name was not the same as the on in the blog – with 6 extra letters on the end (bear that in mind if you try this), the file once grabbed with WGET was not in the /tmp directory contrary to the instructions – (I used ./ instead) and once all of that was done  - the address of the new router was not 192.168.1.1 as promised but 192.168.100.1 – that cost me half an hour Smile Oh – and the –vn command in the instructions turns out to be a –n command !!

    Anyway at the end of it all I ended up being able to Telnet (Windows command line with address as parameter) to the new OpenWrt router on my little sub-£4 box.

    But all was not well (again) – There was an instruction to change the password – and this was also suggested in the blog above.  Simple enough except when I did that it said “No space left on device” – not enough even to put a new password!!?!?!! Then I remembered of course that I’d left the openWrt install file in place – so using RM I got rid of that and NOW I could update my password. I was expecting at this point the Telnet service to stop working and SSH to start working.

    And so it did – but can I HELL log in with SSH – I have Bitwise SSH client on the PC – I can see it knows about the router as other addresses provide different error messages but it simply WILL NOT log in.. 

    Update 7/7/2016: WELL it turns out that the version of openWRT I used didn’t have SSH activated – yes, amazingly after telling people to put a new password in – and then rely totally on SSH – it was not installed.

    It turns out that inside the unit  there are 4 connectors – 3 are relevant as they are ground, serial in, serial out. They can be attached to an FTDI at 57600 giving access to the shell (a 2013 version I may add). I changed the address in /etc/config/networks  using the built in VI editor – to one in my address range and added a gateway. This then enabled me to grab another version of the openWRT software… here ..https://wiki.openwrt.org/toh/unbranded/a5-v11 and the link I used was  http://192.168.100.249:8080/openwrt-15.05-ramips-rt305x-a5-v11-squashfs-sysupgrade.bin

    On reboot I could see I had a NEW shell (2015) and I set the password again – and set the address again as this was all lost in the update.

    NOW I could SSH into the unit and use the shell in a terminal.

    In theory all that is left is to mount a memory stick – expand available space and add in the full graphical environment? Well, plugging in a memory stick works – it is acknowledged in the shell – erm, but no SDA1 appears in DEV…

    I started to follow these instructions for adding block device support

    opkg update
    opkg install kmod-usb-storage block-mount kmod-fs-ext4
    mkswap /dev/sda1
    swapon /dev/sda1
    mkdir -p /mnt/share
    mount -t ext4 /dev/sda2 /mnt/share -o rw,sync

    And about half way through the second line I ran out of storage on the device!! However the installation continued. At the end of line 2 above I was getting pretty depressed – but checked – and sure enough I had an SDA and SDA1 in /DEV/

    But no room to do anything – not even to create /mnt/sda1 or similar. Just utterly out of room. and finally – after trying various image with varying success I tried the image in this project - https://github.com/sternlabs/RT5350F-cheap-router and – BRICKED. Project on hold until another unit arrives Smile

  • Facebooktwittergoogle_pluspinterestlinkedin