Tag Archives: Raspberry Pi 3 opening – WIFI and Bluetooth

Raspberry Pi 3 Grand Opening

Raspberry Pi 3  packagingAfter a couple of tense hours, the doorbell rang this morning – the RS delivery guy with my brand-spanking new Raspberry Pi 3.

So was it worth getting? Is this going to kill the competition? Should I have stopped in bed?

The Pi arrived in the usual oversize box – and I quickly opened it up only to find a load of packing and inside, a much smaller box.

Some day the various suppliers will “go green” and stop doing this – however – I opened up the smaller box to find – my Raspberry Pi 3 – which just happens to look almost identical to the previous model except for a few minor layout changes and a new chip + chip antenna.  So the first answer is – YES your existing boxes and connectors will fit.

Raspberry Pi 3[8]If you read my blog from yesterday you’ll know that the big differences here are greater clock speed, Bluetooth 4.1 and WI-FI – all welcome additions to the new Pi.

The new board is powered by a 1.2GHz, 64-bit quad-core ARM Cortex-A53 CPU, a step up over the 900MHz, 32-bit quad-core ARM Cortex-A7 processor used in the previous models. The new processor and other improvements should make it up to 50% faster than the Pi 2 in 32-bit mode and up to 10 times faster than the original Pi. I say “should” as I’ve not tested this.

Raspberry Pi 3[6]I’d already downloaded the latest Raspbian (dated 26/02/2016) and popped that onto a handy 16GB microSD card – all that remained was to plug everything in and switch on.

I turned on the power and…. the usual on-board red light came on and the normal boot up text appeared no problem!  After perhaps 10 seconds the screen blanked momentarily and up came the familiar Raspberry Pi graphical environment.

This time however, in the top right hand corner of the screen, twin monitor icons flashed to say that three access points could be seen!

I noted that Node-Red, complete with GPIO control is up and running – but what I could not see immediately was anything to do with Bluetooth – which seems a little odd. Try as I might I could not find any reference to Bluetooth – so just for the sake of if I popped open a terminal and did the usual “sudo apt-get update” and “sudo apt-get upgrade” but about the only thing that came to my attention was the upgrade of Node-Red from 0.12.5 to 0.13.3 -  which seems odd given that the version of Debian I downloaded was only released a few days ago.

When you do this incidentally – note that the Node-Red upgrade takes a LONG time – I was convinced at one point that the whole thing had died on me.

 

Raspberry Pi 3

The bad news? No USB3, no SATA, no PCIe  - but then this was to be expected – 2GB of RAM would have been nice too – but then they did manage to keep the price the same.

I went into the graphical setup for Raspberry Pi configuration, told it to expand the file system (why don’t they do that automatically), to disable serial (so that it can be used in Node-Red) and to enable SPI, I2C, SSH and the camera (i have a little camera module). I also changed the hostname from “raspberrypi” to “raspberrypi3” – sensible while I only have one of them.

I went Googling for Bluetooth on the Raspberry Pi 3 and of course, by and large the reviews out there are the usual – people re-gurgitated press release material and not actually testing anything so every review I found just blindly said “and now with WIFI and Bluetooth”

 

I noted that the NOOBS installation was 2 days younger than the Raspbian file so I went and installed that – and grabbed Raspbian – same result even after update and upgrade.

Here is a solution for the missing Bluetooth…

sudo apt-get install blueman bluez pulseaudio-module-bluetooth --install-suggests

My thanks to Brian Moses on Google+ for that one -  LO AND BEHOLD a Bluetooth symbol on the top of the screen – I put my H800 Logitech headset (which works with everything) into discover mode – and pressed search on the PI – again – everything worked – head headset was recognised and is now trusted… I pulled up a typical Python game after CONNECTING at which point the Bluetooth symbol turned green and… works a treat.

Facebooktwittergoogle_pluspinterestlinkedin